Fixing Logos Citation Formatting

There are several steps to get this working (don’t blame me, blame Logos).

1. Select Citation Style

You will need to create a custom style. These are two options (modify as needed/desired):

With Verse Numbers

%NoFootnotes
%NoCitation
%UseBibleParagraphs

=Header
<p>
<b>[FullPassageRef] ([Version])</b>:
»
=ForEachVerse<sup>[VerseNum]</sup> [VerseText]
=Footer
«</p>

Without Verse Numbers

%NoFootnotes
%NoCitation
%UseBibleParagraphs

=Header
<p>
<b>[FullPassageRef] ([Version])</b>:
»
=ForEachVerse[VerseText]
=Footer
«</p>{
}

2. Set up Scripting

You will need a clipboard handler (or similar) that can be scripted, unless you want to do this manually every time you need to cite something. If you’re using macOS, I highly recommend Pastebot [eventually, I’ll make this a link].

There are four steps. Technically, you need only the first two, but the third and fourth fix improper quotes (i.e., those with a closing, but no opening, quotation mark), and so it’s best to use all four.

  1. find: »\n+
    replace: »
  2. find: \n+«
    replace: «
  3. find: (»([^“"].*(”|"))«)
    replace: »“$2«
  4. find: »(.*)"
    replace: »$1”

3. Test and Implement

Make sure everything is working as intended (feel free to paste a verse or a handful of verses into this thread) and then create a keyboard shortcut for your new ‘paste with formatting’ option (I use control + shift + v).


These can, of course, be easily modified to change quotation mark style (e.g., » and « to and ) or any number of other things.